Tag Archives: backup

When disaster strikes

It’s been a bad week for technology at Snaptophobic Towers. Our “standby” MacBook Pro developed a fault with its logic board, which meant it failed to boot and went straight to a kernel panic. On a recommendation, we took it to an authorised Apple repair agent in Kingston upon Thames, and it’s hoped the machine will be fixed for a reasonable price and back with us again pretty soon. (The failed machine is used by Best Beloved, and so has everything set up for someone who has difficulties with sight, so it would be handy to have it back again.)

Having been out on a shoot today, I returned and set about backing up the RAW files to my backup drives before I imported them Aperture. I have a pair of matched 500GB external drives, Archive A and Archive B, and I literally manually copy from the CF card to each drive in turn. Once the copies have been made, the drives are unmounted and powered down. The reason for making backup copies this way to try to eliminate the risk of data corruption that might occur copying from one drive to another: each copy process is from the original card image. With two matched drives—not in a RAID configuration, I may add—if one goes down, at least the other ought to remain, at least until I can source replacements.

Anyway, I powered the drives up, but only Archive B mounted to the Mac’s desktop. I’d been having some odd issues with Archive A, which ought to have warned me this was likely to occur eventually. I launched Disk Utility to see if it appeared in the drives list. It did, but only the drive itself. The partition was greyed out.

I unmounted the drive through Disk Utility, and tried connecting it with a different socket. Same problem, and the same again when connected with USB. Running First Aid reported some errors on the catalogue, so I let the repair process run its course. All came back as passed, but the drive partition still refused to mount. I ran First Aid a couple of times, but no joy.

At this point, I was resigned to the drive having failed completely in some way. I tried taking the drive out of the case and connecting with a caddy system to see if it would mount that way. Nope. Not playing. Putting it back in the case, I considered my options. Both drives were nearing capacity, and I was planning on purchasing two new drives to start a fresh archive. The old archives were to be stored, preferably one of them off-site. With one working archive drive, I thought perhaps it was time to bring that purchase forward.

Meanwhile, with nothing to lose on the “broken” drive, I decided to try erasing and reformatting it. Would you believe it? The drive mounted as normal after this. It lives to die another day. I’ve set about copying the Archive B over to the reformatted Archive A, but I am still going to replace them both with new units. Having checked out the prices of 500GB external drives, I realised it would be more sensible, not to say economical, to purchase replacement internal units and re-use the old cases. The old internal units can be safely stored off-site, and I can restart the archive on the “new” drives.

The moral of this tale is, I suppose, if you use electronic media to store valuable data in any form, back it up. There is a saying you should back everything up three times, on three different forms of media, and in three different places. That’s not always practical, so I try to do the best I can. I like to think my system of two identical drives, plus my Aperture libraries, gives me some measure of reassurance. The sad fact is, though, that any hard drive is living on borrowed time. Drives will fail, it’s just a case of when, and making sure you have backups of your data so you can restore things and not lose anything.